Currents - Rest API endpoint recovery – Incident details

Rest API endpoint recovery

Resolved
Operational
Started 13 days agoLasted about 3 hours

Affected

API

Major outage from 2:30 PM to 5:30 PM

API - HTTP REST API

Major outage from 2:30 PM to 5:30 PM

Updates
  • Resolved
    Resolved

    The error has been resolved, and the proper configuration restored. An internal issue has been logged to review the incident and look for future deployment improvements.

  • Monitoring
    Monitoring

    Some incompatible settings from a failed deployment were left in place after a rollback, and our rest api endpoint was unreachable for the past 3hrs.

    Spot instance reset requests, and calls directly to our api endpoints were impacted.


    We implemented a fix and are currently monitoring the result.