Currents - API - Dashboard degraded performance – Incident details

API - Dashboard degraded performance

Resolved
Minor outage
Started over 2 years agoLasted about 3 hours

Affected

API

Data Pipeline

Minor outage from 4:05 PM to 6:38 PM

Updates
  • Resolved
    Resolved

    We just resolved the issue!

  • Monitoring
    Monitoring
    • We implemented a fix and currently monitoring the result
    • Due to the outage some items take longer than expected to appear in the dashboard.
    • We are running a process to validate data integrity and backfilling the missing data in Elasticsearch cluster.
  • Investigating
    Investigating

    We are currently investigating this incident.

  • Identified
    Identified

    We are continuing to work on a fix for this incident.

    • The requests to a downstream Elasticsearch dependency have been timing out.
    • Initiated increase of Elasticsearch cluster capacity